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Medtech32
Interbase 2009 Back Up and Restore
Instructions

Technical Documentation

med

NEW ZEALAND
TECHNOLOGY FOR HEALTH

This Documentation contains important information for Medtech32.
Please ensure the Technical Documentations are circulated amongst all your IT staff
and/or IT service providers.
We suggest these should be filed safely for future reference.
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Overview of Interbase 2009 Backup & Restore

Warning
e Before you proceed, please ensure that you have A SUCCESSFUL DAILY BACKUP of your
data — preferably from the previous day.

INTERBASE BACKUP AND RESTORE CHECKLIST

Pre-Backup & Restore Checklist

Briefcase Data Check-in

Daily Backup

Interbase Backup and Restore Database Optimisation

Interbase Backup

Interbase Restore

O odo|jg|d
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Pre-Backup & Restore Checklist

Warning
e Before you proceed, be sure to log into the computer with full Administrator rights.

Pre-Backup and Restore Checklist
The following checklist is required to be completed to ensure that you successfully perform your

Interbase Backup and Restore.

[ ] Briefcase Data Check-in

[] Daily Backup

[] Interbase Backup and Restore (Database Optimisation)
[] Available Space

[] Stop Medtech32 Scheduler, NIR Directory Monitor Tool, Generic Directory Monitor, and

ManageMyHealth Online Appointments Manager

Briefcase Data Check-in

ALL NOTEBOOKS used for Briefcasing should be checked in prior to performing the Interbase
Backup and Restore.

Daily Backup

It is essential that you have a successful backup prior to commencing the backup & restore
process. This backup needs to be recent - preferably from the previous day. If you do not have a
successful backup or do not know how to ascertain if you have a successful backup, STOP
NOW! and contact your engineer.

Interbase Backup and Restore

We recommend that you perform an Interbase Backup and Restore on all databases at regular
intervals. E.g. MT32.ib (Patient Database), Blob.ib (Scanning Database) and Training.ib (Training
Database).

Available Space

You must have a minimum of the total size of all databases combined, as available space on the
server hard drive, to perform this procedure.

To locate this information on the server, double click on the My Computer icon, then double click onto
the Drive that contains Medtech32, locate the MT32 folder, then double click onto the Data folder.
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Please note the size of the each of the database files above MT32.ib, Blob.ib, Training.ib. (To view file
size details select the menu option View / Details)

To ascertain available space: Double click on the My Computer icon, then right click onto the Drive
that contains Medtech32 and select Properties. The amount of available space is listed.

Stopping MedTech32 Scheduler, NIR Directory Monitor Tool and Generic Directory Monitor

Ensure that you have stopped the Medtech Scheduler (normally located on the computer with
HealthLink installed), the NIR Directory Monitor Tool, the Generic Directory Monitor and the
ManageMyHealth Online Appointments Manager.

In order to determine if these applications are running, check the taskbar on the computer with
HealthLink installed. If these icons are present, then you would need to shut down these applications.

Note
If you restart the computer, it will attempt to re-activate the Utilities Tool if the tick in “Run at
Windows Startup” is enabled.
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Briefcase Check-in

Warning
e Please ensure that you have printed and read the following documentation.

Briefcase Check-in

The following instructions are an excerpt from the Briefcase Installation instructions. For further
information to troubleshoot the check-in process, refer to the above-mentioned instructions.

Open the Briefcase Administrator

Double click on the “Shortcut to bcadm.exe” (Briefcase Administrator) icon from your desktop.
(Actual file is located in C:\MT32\Bin\BCADM.exe)

Check In the Database

Click on the “Merge the Changes ...” option or via the menu select “Options » Merge
Database Changes”.

= Briefcase Administrator [10.0]
File _Qofjons Help

)

Time |Event |Dbiect |Detai|s

081904 INFORMATION SERWER PATH='D
081904 INFORMATION SERWER Location is
08:19:04 INFORMATION SERWER Database M
08:19:04 INFORMATION SERWER Database M
08:19:04 INFORMATION LAPTOP PATH='D
08:19:04 INFORMATION LAPTOP Location is
08:13:04 [NFORMATION LAPTOP Database b

4 |NFORMATION LAPTOF

Confirm that you wish to continue by clicking “Yes”
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Please wait while files are merged back to your Server...

Database Merge Complete

Click on “OK” and Exit the Briefcase Administrator.

Xl
@ Database Merge Complete
=1Briefcase Adminis: =14l x| )
File Options Help
Time |Event |Dbiect |Details :l

02:24:37 DISCOMMECT SERVER Disconn
033506 COMMECT SERVER Connec!
08:35:06 COMMECT SERVER Connecl
033506 COMMECT LAPTOP Connec!
08:35:06 COMMECT LAPTOF Connec!

08:35.07 MERGE Databas
0&.35:07 MERGE LAPTOP Searchit
023507 MERGE LAPTOP Scannin
08:35:07 MERGE Synchra
083507 MERGE SERVER Adjustir
083508 MERGE [ratabas

083508 DISCOMMECT SERWER Disconn

083508 DISCOMMECT  SERWER Disconn

083508 DISCOMMECT LAPTOP Disconn—l
2 DISCOMMECT LAPTOF Dizconr ;I

2
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Interbase Backup and Restore Documentation

Warning
Ensure that you select the correct documentation relevant to the version of Interbase installed on
your server (Interbase 2009)

Documentation

Click on the “View Upgrade Instructions » Additional Documentation” and then select the
Documents folder and the relevant Interbase Document folder.

@ MEeEDtechs32

Install/Upgrade
MedTech32

View Upgrade Instructions

MT32 Server Upgrade Instructions

MT32 Briefcasing Upgrade Instructions
MT32 Release Motes

IE 7.1 Auto Backup and Restore Instructions
16 7.1 Auto Upgrade Instructions
Additional Documentation

View MedTech32 Tuterials
[~ Advanced Options

2004} Health Technology Ltd

Open IB Console

Select Start »Programs P CodeGear Interbase 2009 [Instance = MedTech_IB09]
»IBConsole”

o]
H Programs . Wordieb
Tools4ever 3

L .
. Favorites 3 Documentation
. ¥ ‘F' IBConsole
£+ Documents 4
Eﬂi InterBase Server Manager
E Settings » |Z] License Agreement
License Manager
\} = =

Check the Interbase Version
select “Help » About”
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#[j 1BConsole

Conzale  Wiew Server Database Tools  Windows | Help

@@r_b %|%§LT—-' Conkents
E@ InterBase Servers E LDET;C;E:;T;
b >@ Local Server InterBase Help

medtech”

The following screen will display the current version of Interbase installed on the server:

About IBConsole 2009

009

INTERBASE SMP

Werzion: 9.0.3.437 hittp: A, codegear. comdinterbase

Copyright 2 1986-2008 Embarcadera Technologies. Inc. hitbpe v, codegear. com

YWindows =P [Buld 2600 Service Pack 3]
Includes contributions from

Frzpsztof Golko, Gelein van de Woorde
Ferformance Monitoring by

Craig Stuntz and Andreano Lanusse
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Interbase Backup

Search for existing .BAK files

Existing BAK files may cause some confusion when restoring databases, therefore we
recommend that you search for the existence of a file before proceeding.

Select “Start P Search WFiles/Folders” then type file name e.g. MT32.BAK (Blob.BAK,
Training.BAK),Click on ‘Search Now’.

If any existing MT32.BAK files exist they will be displayed on the right hand side of the screen. If
no files are located proceed to Step 4.2.

Click onto the file then press the ‘Delete’ key on the keyboard.

Select ‘OK’ to confirm the deletion of the file.

LETTE T ~1oi x|
Fie ER Vs Fovrbes Toos  Help -
=ik v oo - (5] || @sewch LyFoders (o | B5 B X o | EH-
dddress [4] Search Resits | e ||k
Sesrch L e—

QHEH Q NA|MT i BAK 1
9 Search for Files and Foldens |
5 r named
T2 bk
Combapnirg best
I
Lok n
[jF.i::el“-nddn-!sIE Li] ﬂ
[Seachban] i | |l | |

1 dgectis) &

Open IB Console

On the Server, Go to Start » Programs » CodeGear InterBase 2009 Instance =
MedTech_IB09 » IBConsole.

wiordi'eh
Toolsdewver

Programs

L
N Favarites
x Documents
1T
Settings 3 E] License Agreement
—. License Manager
1 [=S N =

Go to Interbase Server, Right Click and select Add
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Local or Remote Server %I
Select the kind of server you want bo add.

) Local Server

%) Bemote Server

Mest » H Cancel ]

Select Remote Server and click Next

Add Server Wizard

Remote Server Setup %

Specify the name aof the server

| H Browsze netwark ]

Specify the inztance name [default: gds_db)

| gds_db |

Optional zpecify an aliazhame

Select the network, protocol you want bo use

TCPAP v

Cancel

Click on Browse Network and browse to the Medtech server computer on the Entire Network
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Browse for, Computer,

Select server

= ‘:{ My Metwork Places
= g Entire Metvaork,
fﬂ Microsoft Terminal Services
= fﬂ Microsoft Windows Metwork,
[+~ %y Win
fﬂ Symantec SMAC MNetwark Provider
fﬂ web Client Network,

BB

o | Coma )

Type in Specify the instance name as MedTech_IB09 and click Next

Add Server Wizard

Remote Server Setup %

Specify the name aof the server

Iinlu:ugiu:puﬂ 1] Browse nebworl:

Specify the instance name [default: gds_dhb)

|MedTech_|Bna

Optional specify an aliazname

Select the network protocol you want o uge
|TcPAR |

< Back | MHest > Cancel

The following screen will be displayed and enter the Password as masterkey and click Next.
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Specify Credentials %

Servers prior to version 6.0 do not accept logins.

Check the registeranly checkbow if the wversion iz below 6.0,
Y'ou can alzo check the registeranly checkbow if you do not
want bo make a connection now.

[~ Begister only
Uzemame ISYSDB.&.
Pazzword I“““”“““”“ IJze Default I

[~ Save pazzword

< Back Mewt » Cancel

And the screen below will be displayed. You can enter a description for the Server, its
optional and Click on Finish.

Add Server Wizard

Finish YWizard %

Optional you may specify a description far the server.
[t will be wzed by IBConzole anly.

¢ Back Finizh Cancel

The Interbase Server will now be displayed in the IB console
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o

Console  Wiew Server Database Tools Windows Help

FAE AN R AT

@ InterBasze Servers Action | Description

E‘g Laogout Lagout from the current server
Uszer Security Manage InterB aze Users
Properties Wiew Server properties

Database Aliager  Show Database Aliases

0T Configuration  Configure settings far Over-The*/ire encryption

Login to the Interbase Server

Right Click onto the Server and then select the Login menu option

SI=TE

Console  Wiew Server Database Tools Windows Help

¥ ewg | -

Interk aze Servers Action | Dezcription

; >g Autalogin Ao login
Remove | . .
Login Login ta the selected server
I Remove Remove an InterBaze Server
Logout Diagnoze Connection  Diagnose a connection to a server
LIsEr SECUrity .. Froperties Wiew Server properties
) ) 0T Configuration Configure settings for Over-The#ire encryption
Wiews LogFile: ...
Diagnose Connection ...
OTW Configuration
Properties ...

Enter Password
User name is “SYSDBA”, enter the password “masterkey” then click on the “Login” button
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Server inlogicpe10 - MedTech_|BOS

Uszer Mame: IS"r’SDB.-’-‘-.

Paszword: I

Save password [

Default | Login LCancel
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Register database

Register Databases

Click onto plus (+) sign to the left of Server (the plus (+) will change to a minus (-) sign and
display additional options).

Right Click on “Database” and select “Add”

€| 1BConsole

=10l x|
Consale  VWiew Server Database Tools  Windows Help
¥ ew s -

@ InterBasze Servers

Mame | Fath
E‘g inlogicpc10 - MedTech_IEOS
: Add ... i
Create Database ... I

Enter the path to the MT32\Data directory C:\MT32\Data\MT32.1B

Note
The Medtech32 databases will be listed under the Server / Databases menu once you register the
databases.

The name of the selected database will display within the “Alias” field automatically. Select “OK”
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#l§ Add Database and Conneck

SErver inlogicpz10 - MedT ech_|BOS

— Databaze
File: |CAMT32\DatabM T 32 1B J
Aliaz Name: IM 2

v Save Aliaz Information [T Usze Aliaz for DB Connect

— Lagin Infarmation

User Mame: ISYSDB.&.
Pazsword: I"““““ lze Defaults |
Role: I

[T Caze sensitive role name

Default Character Set I j

[ Save Paszward

X Cancel

Note

o Repeat this process above to register all of the databases included within the MT32\Data

folder, for example the “Training” and the “Blob” databases.

Interbase Backup

Select the Backup option

med

Select the “Database » Maintenance » Backup/Restore » Backup” menu option

#j 1BConsole

Conscle  Yiew Server | Database Tools  Windows Help

I (=] e

| Description

Digconnect from the curent database
Show database properties

Display database statistics

Shutdown the databaze

Perform a database sweep

Backup ...

Restore ...

IModify Backup Alias ...

Delete Alias
cted to the server

lidate the database structure

e | 'R ﬁ add ...
@ InterBaze Servers Benass Achion
E‘g inlogicpc10-Me Connect Disconnect
[_j@ Databases  Conneck As . Properties
E@ Disconnect Database Statistics
""" L create Database ... Shutdown
""" amT Crop Database Sweep
E iy Maintenance Backup | Restare
----- i@ s :;j;ol;n;‘:;;:tzojltmm Database Statistics ...
------ @ T Sween
------ x B Connected Users ... Database Yalidation ...
...... [ Properties ... Transaction Recovery ...
""" @ Exceptions Shutdown ...
""" & Biob Filers Database Restart
...... Y Roles
------ & zer Permizzions
----- &5 Backup
------ Server Log
------ w Users

ke Performance Monitor

py the content of thiz D atabase to a new database
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Define the Backup Information
This screen defines the path where the backup file will be saved to.

Database Section: The database “Alias” should default the selected database, for example MT32.ib

#j patabase Backup

SErver inlogicpz10 - MedT ech_|BO3

D atabaze

Alias: C:AMTI2NDatahT 32 B

Backup Files Section: The Server should default to “Server name -MedTech_IB09”.

Within the “Alias” field type the name of the backup file eg “MT32.BAK” and Within the “Filename”
field enter the path for the backup file eg “C:\MT32\DATA\MT32.BAK”

Backup File(z]
Alias: |MT3ZBAK =]

Filername IE:"\MT32'\Data'\.MT32.B.-’-'-.K
[T Usze multiple files [T Femenber Settings

Ensure the Format option is “Transportable” (top right hand corner)

Optionz
’7 Farmat Tranzpartahle j

Select the “OK” option

Server: inlogicpc10 - MedTech_BO3
— Databaze — Dptions
Slias CAMTI2\DatsMT3ZIE Format | Transportable =
tetadata Oy IFaIse j
'-'—' Garbage Collection ITrue j
et Tranzactions in Limbao IProce&s j
Aligs: IMT 32.BAK j Checksums I Process j
Filename |C:4MT 324D atathT32 BAK Corrvert to Tables fFake =l
[~ Use multiple files [~ Bemember Settings Yerbose Dutput e Ersem

/QK I x LCancel |
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You should now have the following screen displayed

med

_ioix
File Edit
EIR R

ghak: writing domain RDESS0& -

ghalk: writing domain RDE3SO07

ghalk: writing domain REDESS0S

chak: writing domain RDE$SO09

ghalk: writing domain RDE3S10

ghalk: writing domain RDE3S11

ghalk: writing domain RDESS1Z

ghalk: writing domain RDE3SS13

ghalk: writing domain RDE3S14

ghalk: writing domain RDE3S15

ghalk: writing domain REDESS1a

ghalk: writing domain BEDESS17

ghalk: writing domain RDE3S1S

ghalk: writing domain RDE3S19

ghalk: writing domain RDESSZ0

ghalk: writing domain RDE3SZ1

ghalk: writing domain RDESSZ:2

ghalk: writing domain RDESSZ3

ghalk: writing domain RDESSZ4

ghalk: writing domain RDE3SZS

ghalk: writing domain RDE3SZS —
KN — _*I:I
| 1: 1 |Read-0nl\,-' | v

Wait for the backup to complete

This may take several hours

When the “Database Backup Completed” prompt appears click on “OK”

@ Database backup completed.

x|

Note

If an error is displayed at the end of the process do not proceed any further. Please call our

Support Services on 09 358-0116 or nzsupport@medtechglobal.com for further assistance.
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Close Backup Dialog

Select the “File » Exit” menu option

i} Dotsbase Backop

i Fin Bt

T writing Cconsteai
ghak: wricing constrai
ghak: writing consteai
ghak: wricing consteai

Copyright © Medtech Limited 2010
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Interbase Restore

Note
e The Restore Option may take longer than the Backup Option — in some instances this could
even take twice as long. You will need to perform the restore on all databases registered. E.g.
MT32.ib, Blob.ib, Training.ib

Select the Restore Option
Select the “Database » Maintenance » Backup/Restore » Restore” menu option

“} IBConsole

Console  View Server EetletR 8 Tools Help
Y || ae.
FE InteiDace Servers Import Databases o Description
+ 76 Local Server - M ogout Logout from the eument server
= Jg o1 Securly Manage InteiBase Users
Dalabases Propeities Wiew Setver propeities
ﬂ Backup Precennect stabace Alazes  Show Database Alases
E] Severlog|  Creste Database ...
E Uzers

[ Montenance ———+ —padup /Restoe+

Define the Restore Information
This screen defines where the data will be restored to.

Backup File Section: Within the “Alias” drop down listing select the file menu

#[j patabase Restore

SErver inlogicpz10 - MedT ech_|BO3

— Backup File[z]

Blias: |File... =l

Filez

*|
=

Click on the ﬂ option and that will ask you to specify the Additional file and enter the default path
where MT32.BAK is stored.
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Specify Additional File

med
il 4

M arne: |I::"«MT32"\D ata\MT 32 BAK]

o OK

X Cancel |

Click Ok to this screen and the File name will be displayed in the Files section as shown below.

#[j Database Restore

Server inlogicpz10 - MedT ech_|BO3
— Backup File[z]
Blias: |File... =l
Files C:hAT 324DratahT 32 BAK,

*|
=

Database Section: The “Database Server” should default to “Servername- MedTech_IB09”
and the “Database Alias” should default to “MT32”. The file name should default to the data

directory of Medtech32 “C:\MT32\Data\Mt32.IB”

— Databaze
Alias:

-

|MT32

Filename IE:'\MTBE'&D atahMT32IE

[T Usze multiple files [~ Remember Settingz

Change the “Overwrite” to “True”

Options
Fage Size | 4035 =l
Overwite -

Select the “OK” option — you should now have the following screen displayed:
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Server inlogicpe10 - MedTech IBO3
— Backup File[=] — Options
Blias [Fie... =l Page Size [ 4035 =l
Files CAMTI2AData\M TI2.BAK, D >
ll Commit &fter Each T able IFaIse j
;l Create Shadow Files ITrue j
- Deactivate Indices I Falze j
— Datahase Walidity Conditions IHestDre j
Alias: IMT32 j |Jze &ll Space IFaIse j
Filename IE:'\MTBE'\Data\MTBZIB Werbose Output IN.;.ne j
[~ Use multiple files [~ Remember Settings \alidation Check IFaIse j
Preallocate Pages IU
SEP |
Decrypt Pazsword I

x Cancel |

Wait for the restore to complete

This may take several hours

When the message “gbak: finishing, closing and going home” is displayed the restore has
finished.

Note
If the message, (as shown above) is not displayed, or an alternative message (eg. “request
failed”) is displayed, do not proceed any further. Please call our Support Services on 09 358-
0116 or support@medtechglobal.com for further assistance.

Information [‘S_<|

@ [ratabaze restore completed.

Close the Database Restore Window
Close the window
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° | Datshase Restore b
Bmchoup Filsls) Dgdors:

Sepver Local Serve Page Gize (Bytes]| l—_|‘m
St ||=i., ll = - .
Coormanit fter Esch Tabis False
et % Cometz Shadom Fis Trie
P Mt biT |
O et Dl MIT 3B LA [ False
/R - [Pz
——— e
s Werbose Output [To Screer
B |Luc-!'5!mel Bl
|ﬁmmu(=] |PW" |i|
DT 3D T 3218 =
— i
P

Close Interbase Console
Select the “Console/Exit” menu option

“F IBConsole

C View Server Database Tools

= R AT

@ InterBaze Servers

Login to the Medtech32 Database
Log into Medtech32 and check that recent data is present. We recommend that you

» Search for a patient (F2)

» Display the Appointment Book for today (F7)

» Check the last three patients within the appointment book have invoices displayed within their
Account holder screen (Shift + F9)

» When restoring the Blob file ensure you can view three recently scanned documents

Delete .BAK files

Warning
Do not delete the .BAK file until you have checked that the restored data is up to date and
current.

The BAK file can be deleted to allow for more space within your hard drive.

Select “Start » Search »Files/Folders” then type file name e.g. MT32.BAK (Blob.BAK,
Training.BAK)

Click on “Search Now”.

If any existing MT32.BAK files exist they will be displayed on the right hand side of the
screen.

Click onto the file then press the “Delete” key on the keyboard.

Select “OK?” to confirm the deletion of the file.

VV VYV V
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| Fle Edk Vew Fovobes Toos  Help
| dmzih v o o (|| Phsencn CiFodes (dtery | g B2 X wy | E-
Jldli'wlad aarch Rasults 1] o “L""'*
Saarch 4 ru‘_"hq..
A | D | SR
& Search for Files and Foldess 4
WHM
{,‘ I bk ‘J J
Cordainirg best
I
Lok in
[= Lot Hardaitves 1001 =l
e | 2
[1 clmckiz) i

Should you have any questions with regard to the information contained in these Release Notes
please don’t hesitate to contact the Medtech Helpdesk on 09 358 0116 (Option 1 and follow
prompts).
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