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These Release Notes contain important information for all Medtech32 users. 

Please ensure that they are circulated amongst all your staff. 

We suggest these should be filed safely for future reference. 
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Prerequisites 
 

Please review the following pre-requisites and ensure they are met prior to 

running the Update: 

 

• Ensure the minimum version and build requirements are met. 
 

IMPORTANT NOTE 

 

Your practice MUST be on Medtech32 VERSION 7.5.0 BUILD 3035 OR ABOVE 

to upgrade from InTouch SMS and/or setup ManageMyHealth™ SMS.  If 

you ARE NOT currently on this version or higher, please DO NOT continue. 

 

This can be checked by logging into Medtech32 and selecting Help ► 

About Medtech32. 

 

• Ensure the person(s) who will be performing the upgrade/setup have 
READ THROUGH the release notes. 

 

IMPORTANT: This document contains valuable information that, if not 

read, could seriously affect the upgrade/setup process and/or possible 

down time of your network. 

 

• Ensure you are ALWAYS logged onto Windows with ADMINISTRATIVE 
RIGHTS when performing ANY installation, update, or maintenance 

tasks. 

 

• "User Account Control" (UAC) MUST be DISABLED as a policy across ALL 

Server and Client computers that are running on Windows Vista or 

Windows 7 or Windows 2008. 

 

• ManageMyHealth™ SMS MUST be setup and run on the Medtech32 
Server ONLY.  It CANNOT be run on any Medtech32 Client machines or 

Briefcasing laptops. 

 

• Ensure you have ALREADY APPLIED for a ManageMyHealth™ SMS 
Account and have ALREADY RECEIVED the Username and Password. 

 

NOTE:  A copy of the Request for SMS Account for Medtech SMS 

Service form is attached at the end of this document. 
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Introduction 
 

ManageMyHealth™ SMS (previously called InTouch SMS) enables practices to 

send SMS reminders via the ManageMyHealth™ Portal to your patients from 

Medtech32.  It is fully integrated with Medtech32 to provide an audit trail on 

patients who have been contacted via SMS reminders. 

 

This release notes provide an overview on how to setup and run 

ManageMyHealth™ SMS, and what changes and enhancements are 

included in this Release. 

 

IMPORTANT NOTE FOR INTOUCH SMS USERS 

 

WARNING: Quite a number of changes and enhancements had been made 

to ManageMyHealth™ SMS (previously called InTouch SMS), including a new 

SMS engine that runs as a Windows Service in the background to provide 

improved message delivery and error handling. 

 

Existing customers that are currently using InTouch SMS must first setup 

ManageMyHealth™ SMS (which replaces the existing InTouch SMS) in order to 

continue sending SMS messages from Medtech32. 

 

IMPORTANT NOTE 

 

WARNING: It is HIGHLY recommended to employ ONLY qualified system 

engineers when performing ANY installation and upgrade.  The 

consequences of ruining a database during upgrade could possibly lead to 

data corruptions, and as a result – data loss and systems downtime. 

 

If in doubt, please consult with your IT technician/service provider, or contact 

one of the Medtech Channel Partners listed on our web site: 

http://www.medtechglobal.com/aus/medtech-online-au/support-3.html 
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ManageMyHealth™ SMS Account 

SMS Account Application 
 

Ensure you have ALREADY APPLIED for a ManageMyHealth™ SMS Account 

and have ALREADY RECEIVED the Username and Password. 

 

A copy of the Request for SMS Account for Medtech SMS Service form is 

attached at the end of this document in Appendix A.  Please return the 

completed and signed form via fax to 03 8690 8010. 

 

NOTE: Please allow at least 2 working days (based on Auckland public 

holidays) for activating a new SMS Account. 

 

SMS Account for Multiple Locations 
 

For customers with multiple Locations within the same Medtech32 database, 

or with multiple Medtech32 databases, you can either choose to share the 

same SMS Account across all locations, or apply for a separate SMS Account 

for each location. 

 

NOTE: If you would like to apply for a separate SMS account for each 

location, please fill in a separate Request for SMS Account for Medtech SMS 

Service form for each location. 

 

SMS Account Top-up 
 

Upon activating a new SMS Account, the number of pre-purchased SMS 

messages you have selected when filling in the Request for SMS Account for 

Medtech SMS Service form will be automatically loaded into your SMS 

Account. 

 

As stated in the Terms and Conditions of the Request for SMS Account for 

Medtech SMS Service form, Medtech will automatically top-up your SMS 

Account with the same number of text messages as you have original 

selected, whenever 90% of the pre-purchased messages have been used.  It 

is not necessary to contact Medtech in order to top-up your SMS Account. 
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SMS Account Statement 
 

If a statement of usage is required, please contact the Medtech Helpdesk on 

1800 148 165 � Option 1, or email ausupport@medtechglobal.com. 

 

NOTE: No statements will be posted or emailed unless otherwise requested. 

 

SMS Account Cancellation 
 

If you do not wish to continue using ManageMyHealth™ SMS, you must submit 

a SMS Account cancellation request in writing to the Medtech Accounts 

Department at least 2 working days (based on Auckland public holidays) in 

advance via fax to 03 9690 8010, or email accountsau@medtechglobal.com. 

 

NOTE: Unused SMS messages at the time of cancellation are NOT refundable. 

 

 



  ManageMyHealth™ SMS - Release Notes 

Copyright © Medtech Healthcare Pty Ltd  Page 7 of 30 

ManageMyHealth™ SMS Communicator 

Service 

Prerequisite 
 

If your practice has had a previous version of the SMS Utility, the new update 

will remove the old installation from your system.  However, if the 

"InTouchInterface.exe" utility has been added to your Scheduler, it will not be 

removed. 

 

Delete InTouch Scheduled Task from Medtech32 

 

To delete the "InTouchInterface.exe" utility from the Medtech32 Task 

Scheduler, from within Medtech32, go to Utilities > Scheduler > Configure 

Scheduler. 

 

 
 

If you receive the following message: 

 

 
 

Then you need to select the ‘Start Scheduler’ option, and then select the 

‘Configure Scheduler’ option. 
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The Medtech32 Task Scheduler screen will open and display those scheduled 

tasks that have been set up already. 

 

 
 

� Select and Highlight the line referring to the "InTouchInterface.exe" 
Scheduled Task. 

� Click on the ‘Delete Task’ option. 
� Click OK to the message prompt requesting confirmation for deleting 
the Scheduled Task. 

 

Delete InTouch Scheduled Task from Windows 

 

Note: If the "InTouchInterface.exe" utility does not appear in the Medtech32 

Scheduler, then it may have been set up in the Windows Scheduled Tasks.  To 

check this, go to: 

 

Start > Programs > Accessories > System Tools > Scheduled Tasks. 

� Select and Highlight the line referring to the "InTouchInterface.exe" 
Scheduled Task. 

� Right Click and select the Delete option. 
� Click Yes to the message prompt requesting confirmation for deleting 
the Scheduled Task. 
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ManageMyHealth™ SMS Communicator 
 
A Windows Service called ManageMyHealth™ SMS Communicator had been 

implemented to manage the SMS message data sent from Medtech32.  The 

service will be added automatically upon installation of the 

ManageMyHealth™ upgrade; however it will have the following default 

settings.  

 

• Start Up Type = Manual 

• Service Status = Stopped 
 

 
 
Before using the SMS functionality for the first time, you need to ensure the 

default settings have been changed accordingly.  To change the settings: 

1. Log onto the Server with Administrative rights. 

2. Click on the Start menu > Control Panel > Administrative Tools > Services. 

3. Double-click on ManageMyHealth™™ SMS Communicator. 

4. Select ‘Automatic’ from the Start-up Type drop-down list. 

 
 
5. Click the ‘Start’ button in the Service Status section.  Once the service 
has started, the Service Status will change from “Stopped” to “Started”. 
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6. Right Click on the SMS Communicator Service and select Properties. 
 

� Click on the Recovery Tab. 
� Set the Service to re-start after failures. 
� Click Apply and then click OK. 

 

 
 

7. The screen should display as shown below.  Close out of the Services 
window. 

 

 
 

Database Backup Script Considerations 
 

Because the ManageMyHealth™ SMS Communicator is constantly interacting 

with the database, it is important to stop the service when carrying out 

physical file backups of the databases. 

 

It is recommended that the following commands are inserted into the backup 

scripts (if any), so as to STOP the SMS Communicator service before the daily 

backup process begins, and RE-START the Communicator once the daily 

backup process has successfully completed. 

 

• This task should be undertaken by a qualified IT technician. 
• It is applicable ONLY to a backup of the physical database file. 

 

Stop command to be added: 

NET STOP “ManageMyHealthSMSCommunicator” 

 

Start command to be added: 

NET START “ManageMyHealthSMSCommunicator” 
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Database Maintenance and Upgrade Consideratons 
 

The ManageMyHealth™ SMS communicator MUST be stopped before 

carrying out any database maintenance such as Backup and restore, and 

before carrying out any Medtech upgrades. 

 

 

Briefcasing Checkout Consideratons 
 

The ManageMyHealth™ SMS communicator MUST be stopped before running 

a Briefcase complete Checkout. 
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ManageMyHealth™ SMS Setup 
 

SMS Location Setup 
 

When your practice registers for the ManageMyHealth™ SMS service, you will 

be provided with the User Account details which need to be entered into 

your Medtech application. 

 

To access the ManageMyHealth™ SMS setup screen: 

 

1. Log into Medtech with System Administrator rights. 
 

2. Click on Setup > Location > Location Settings – Double Click on your 
location 

 

3. Click on the SMS tab. 
 

 

 
 

4. Put a tick in the ‘Enable SMS’ checkbox. 
 

5. In “No SMS start time” enter a time to STOP SMS messages being sent 
out (to avoid messages being sent at a time when patients would NOT 

wish to receive them). 

 

6. In “No SMS end time” enter a time to RESUME the SMS messages being 
sent out. 

 

7. Put a tick in the “Enable Appointment Reminders” Checkbox. 
 

8. Enter the Engine URL as shown in the screenshot:  The URL is as follows: 
http://sms.managemyhealth.co.nz/SrvMedTechSms.asmx 
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9. Enter the Practice ID, Username, and Password (provided during SMS 
registration) into the tab at the bottom of the screen. 

 

NOTE: If you do not have these details please contact Medtech 

Helpdesk on 1800 148 165 � Option 1 or email 

ausupport@medtechglobal.com. 

 

10. If your practice uses a proxy server, click on the Proxy Tab and enter 
the Proxy settings – as shown below. 

 

      **Please check with your technician if you are unsure of those details** 

 

 
 

NOTE: 

• If a proxy server is used there should be a single username and 
password for all users and computers using the 

ManageMyHealth™ SMS service. 

 

• In a domain environment the username should be entered in 
the format of domainname\username  

 

• The proxy exception settings should include the following URL, 
protocol, and port number (refer to the ‘Systems Requirements 

document). 

 

11. Click OK. 
 

12. If you practice has multiple Locations, repeat Step 2 to Step 11 for ALL 
other Locations.   
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SMS Outbox Document Template Setup 
 

To use SMS reminders, you will need to create the SMS Template that will be 

utilised for the reminder messages.  The template is created as an Outbox 

Document in SMS format. 

 

To create a new SMS Template: 

 

1. Log into Medtech with System Admin rights. 
 

2. Click on the Setup > In/Out Box > Out Box Document. 
 
3. Click the New icon or press (Ctrl+N). 

 

 
 

4. Enter a unique code and description for the document into the 
applicable fields. 

 

HINT: Including the word SMS as part of the code into the code makes 

it easier to identify.  If creating separate reminders for each provider it 

is also advisable to clearly identify the provider and reminder type in 

the Code and Description fields. 

 

5. Select the applicable Outbox folder for the template from the Folder 
drop-down list.  If required, create a new SMS folder. 

 

6. Select SMS from the Format drop-down list. 
 

 
 

7. Click on the Document tab. 
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8. Enter the message text and add any applicable merge fields into the 
message section. 

 
IMPORTANT: The number of characters which can be included in a 

single message is limited to 159 including spaces and punctuation, and 

expanded merge fields. 

 

NOTE: If you exceed the 159 character limit the system will send a 

second message. 
 

 
 

Use the INSERT button to select the highlighted Merge Field for 

Appointment Date and Time.  It is located under the PATIENT 

KEYWORDS filter in the INSERT window and is called PAT_APP_DATETIME. 

 

9. Click the Ok button to save the template. 
 

 

Validating SMS Message Content 
 

When the SMS Reminder is generated, the patient will receive the message as 

you entered it into the Document tab with the merge fields populated 

accordingly.  Below is an example of the SMS message that will be received 

by the patient. 
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The Message length is indicated to confirm the number of characters in the 

message and the total number of SMS being generated.  In this example the 

number of characters is below the limit of 159, therefore 1 SMS text will suffice 

for delivery. 

 

There are two ways to view the content of the message: 

 

1. Click on Manage My Health > ManageMyHealth™ SMS >  SMS 
Outbox and double click on the message you would like to view. 

 

 
 

2. In the appointment book, highlight the appointment, click on the 
“View an Existing Appointment” Icon (or CTRL + O), then on the 

Ellipsis button next to Reminder SMS1 or 2 to view the detail. 
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Both views also display the message length. 

 

 
 

NOTE: Repeat the ‘SMS Outbox Document Template” process if you wish to 

create different messages for each of your individual providers. 

 

 

SMS Staff Setup 
 

If you wish to use a different message for individual providers you will need to 

create an Outbox Document template for each of them – Refer to the above 

“SMS Outbox Document Template Setup” instructions. 

 

Each staff member who requires to send SMS reminders needs to be set up 

according to the following process. 

 

1. Log into Medtech with System Admin Rights. 
 

2. Click on Setup > Staff > Members – Double Click on the staff member. 
 

3. Click on the SMS Tab. 
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4. Tick the “Enable Appointment Reminders” checkbox. 

 

5. Appointment SMS1 is the number of minutes before the actual 
appointment you want the patient to receive the reminder. e.g.  1440 

minutes is 24 hours. 

 

6. Appointment SMS2 is also provided to allow you to send a second 
reminder which will be closer to the actual appointment time. E.g. 60 

minutes. 

 

7. It is necessary to set BOTH SMS1 + SMS2  for each staff member, but it is 
possible to send only ONE reminder.  Refer to “Sending Appointments 

Reminder” instructions below for details. 

 

8. Select the correct SMS Outbox Document Template from the drop 
down menu. 

 

9. Click on OK. 
 

10. Repeat this process for each provider who will be using text reminders. 
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Patient Register Setup 
 

Determine whether SMS messages should be sent or not sent (as applicable), 

for each patient.  You will need to enter the necessary information into the 

Patient Register (F3) screen. 

 

 

Mobile Number Setup 
 

To add/amend information: 

 

1. Search for the patient. 
 

2. Make the patient active on the palette. 
 

3. Click the Patient Register  icon, or press the F3 key. 

 

4. Click on the MORE tab of the Patient Register screen. 
 

 
 

5. Add or amend the Mobile number and Click the Validate  button. 
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6. International country code prefix will be applied by the system 
automatically by default. 

 

 
 

If the number entered is invalid it will be displayed in red and prompt 

you to correct it. 

 

NOTE: No SMS will be generated if the mobile number is missing or 

invalid. 

 

 
 

Spaces or additional symbols should be avoided, but if entered – they 

should be ignored by the system. 

 

7. Click the Ok button to save the changes. 
 

8. Click the Close button to close the Patient Register screen. 
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No SMS Setup 
 

If the patient has indicated that they prefer NOT to receive any SMS 

Appointment reminders - tick the “NO SMS” checkbox.  This tick box is also on 

the More tab of the Patient Register screen. 
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SMS Appointment Reminders 
 

To send a SMS Appointment Reminder: 

 

1. All ManageMyHealth™ SMS related setups must be completed as 
described in the preceding chapters and Medtech32 must be re-

started BEFORE adding new appointments. 

 

2. Ensure the patient’s mobile phone number has been entered into the 
Patient Register screen and the No SMS box is NOT ticked. 

 

 
 

3. Open the Appointment Book using the toolbar icon or by pressing the 
(F7) key, or from Appointment Pad. 

 

NOTE: SMS Appointment Reminders do not work from the Status Screen 

Queue. 

 

4. Book the patient for an appointment on the desired date/time. 
 

 
 
 

NOTE: There are 3 ways to book an appointment: 

 

Depending on which method is chosen you can create TWO 

appointment reminders automatically (which is the default) or reduce 

to just ONE reminder. 

 

a) With the patient on the Palette, use the down arrow to book the 
appointment = two reminders. 
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b) Type the patient surname into the appointment slot and press the 
TAB key to search for, and select the patient = two reminders. 

 

c) Use the New Appointment Icon  or CTRL + N = gives the option 

of one or two reminders.  It will create two reminders by default, but 

either or both can be un-ticked. 

 

NOTE: If you wish to send only 1 reminder you should use the New 

Appointment Icon  when booking the patient into the 

Appointment Book. 

 

 
 

Using the New Appointment Icon will enable the check boxes and 

allow you to untick one or both of the reminders. 

 

5. If the NO SMS checkbox has been ticked in the Patient Register > More 
tab, the system will NOT generate a reminder. 

 

6. If the patient’s Mobile number is not recorded in Medtech the 
following message will appear. 

 

 
 

a) To Send - Enter a valid Mobile number, Cancel the existing 
appointment and recreate the appointment. 

 

b) To Stop this error from appearing – Tick the ‘No SMS’ tickbox in the 
Patient Register > More Tab. 
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ManageMyHealth™ SMS Outbox 
 

The ManageMyHealth™™ SMS Outbox – Allows you to view a list of outgoing 

SMS messages and their status. 

 

NOTE: By default, with a patient on the palette ONLY the messages for that 

patient will be shown. 

 

 

Viewing SMS Outbox List 
 

1. To access the SMS Outbox: 
� Click on the ManageMyHealth™™ Menu > Highlight 

ManageMyHealth™™ SMS > Select SMS Outbox. 

 

NOTE: To view ALL messages, choose Close Active patient from the 

Patient Menu or use the filter icon to display the required view. 

 

2. Entries are ordered by the “When to Send” column with the latest 
entries at the top of the list by default. 

 

 
 

3. The message status will update as the SMS Communicator processes 
the queued messages. 

 

For example, once a message has been sent, the SMS Outbox will 

show the Date and Time the message was sent to the Messaging 

server.  The message status is then updated to ‘Sent’. 
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4. To view a message, double-click on it. 
 

 

 

5. To close the message, click OK. 
 

6. To close the SMS Outbox, click the  icon in the top right-hand corner 

of the window. 

 
 

Filtering SMS Outbox List 
 

To filter the SMS Outbox: 

 

1. Click on the Filter icon  
 

  

 

2. The Recipient Field will show the name of the patient on the palette if 
there is one.  You can delete this as shown to display ALL Patients. 
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3. Using the Containing Text field you can filter for specific message 
content. 

 

Type the text you are looking for into the “Containing Text” 

field and click on OK. 

 

  
 

 
4. The Type drop down is used to filter by APTMT1 or APTMT2. 

 

 
 

5. The Status drop down enables you to filter by the Status of the 
message. 
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6. If you wish to filter for specific dates you can use the “Date from” and 
“Date to” drop downs fields to set the date range. 

 

 
 
7. Click Ok to apply the Filter. 

 

Printing SMS Outbox List 
 

If you wish to print out the ManageMyHealth™ SMS outbox list (for example, to 

follow up on expired or invalid mobile numbers): 

 

1. Open ManageMyHealth™ SMS Outbox. 
 

2. Set any filters you may require. 
 

3. Right-Click anywhere on the list and choose “Print to”. 
 

 
 
4. The screen below will open, allowing you to select the required printer 
or the Report Manager. 

 

 
 

5. Click on OK to print. 
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Cancelling SMS Appointment Reminders 
 

SMS Appointment Reminder cancellation rules: 

 

• An appointment reminder can ONLY be cancelled BEFORE it has been 
transmitted. 

e.g. while the status in the SMS Outbox is showing as “To Be Sent”. 

 

• Once the status in the SMS Outbox has changed to “Sent” it cannot be 
cancelled. 

 

• If the Appointment itself is cancelled on the Appointment Book or 
Appointment Pad BEFORE it has been transmitted, the Appointment 

Reminder will be updated automatically in the SMS Outbox and the Status 

will change to “Cancelled”. 

 

• If the Appointment is re-scheduled using Cut and Paste in the 
Appointment Book and the original Appointment Reminder has “To be 

Sent” status, the original appointment reminder will be cancelled and a 

new Appointment Reminder will be created. 

 

• It is possible to cancel an Appointment Reminder WITHOUT cancelling the 
actual appointment.  If you wish to do this: 

 

1. Open ManageMyHealth™ SMS Outbox. 
 

2. Highlight the appointment reminder you wish to cancel. 
 

3. Right click and select “Cancel”. 
 

 
 

4. Note: The reminder stays in the Outbox but the status updates to 
“Cancelled”. 
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ManageMyHealth™ Service Logs 
 

A logging utility has been included to provide information about any 

ManageMyHealth™ Services.  This will assist in trouble-shooting transmission 

related issues. 

 

1. To view the logs go to ManageMyHealth™ and choose Service Logs 
from the Menu. 

 

 
 

2. The Filter can be set to display particular types of errors. 
 

 
 

• The Patient field will default to the patient on the palette.  Clear this 
if wanting to view errors relating to all patients. 

 

• The Containing Text field can be used to look for particular error 
details. 

 

• The Application field can be used to select errors relating to 
ManageMyHealth™ SMS or other Services when they are released 

in the future. 

 

• The Level field can be used to select different types of information – 
such as Information or ERROR. 

 

• The “Date From” and “Date To” fields provide the facility to filter for 
a specific date range. 

 



  ManageMyHealth™ SMS - Release Notes 

Copyright © Medtech Healthcare Pty Ltd  Page 30 of 30 

Appendix A 

 


